Javaに関する様々な情報をご紹介します。

Javaに関する様々な情報をご紹介します。
評価

0

サーブレットの設定

こんばんわ。
本日、tomcatのバージョンを新しくしようと思い、
tomcat5.0.28をダウンロードしました。
そうしたら、クラスファイルのコンパイル(javac 〜)
の際に、

C:\javasrc>javac HelloServlet.java
HelloServlet.java:4: パッケージ javax.servlet は存在しません。
import javax.servlet.*;
^
HelloServlet.java:5: パッケージ javax.servlet.http は存在しません。
import javax.servlet.http.*;

のエラーが出ました。今までtomcat4.1.30を使用していた
時はうまくコンパイルできていたのに何ででしょうか?
教えて下さい。宜しくお願致します。

1

回答

4607

閲覧

1件の回答

評価

0

自己解決しました。
CLASSPATHの設定がおかしかったです。
以前のtomcat4.1.30は /common/lib のjarファイル名が
servlet.jarだったのですが、
tomcat5.0.28は
servlet-api.jarになってるのに気がつきました。

質問から6ヶ月以上経過しているので、回答を書き込むことはできません。